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Getting started with Microsoft Excel 
Microsoft Excel and Microsoft Word have a lot in common, since they both belong to the MS Office 

suite of programs. This means that if you are familiar with MS Word, then you already know how to 

use several MS Excel features! 

In the MS Word 2010 manual, you’ll be able to find more information and guidance on: 

 Using the mouse and keyboard 

 Starting the program 

 The Microsoft Ribbon 

 Character formatting 

 Opening, saving and printing files 

 Accessing Help 

 

What is MS Excel? 

Excel is all about numbers! There’s almost no limit to what you can do with numbers in Excel, including 

sorting, advanced calculations, and creating graphs. In addition, Excel’s formatting options mean that 

whatever you do with your numbers, the result will always look professional! 

Data files created with Excel are called workbooks (in the same way as Word files are called 

documents). But where Word starts up with a single blank page, Excel files by default contain three 

blank worksheets. This gives you the flexibility to store related data in different locations within the 

same file. More worksheets can be added, and others deleted, as required. 

You’ll often hear Excel files referred to as spreadsheets. This is a generic term, which sometimes means 

a workbook (file) and sometimes means a worksheet (a page within the file). For the sake of clarity, I’ll 

be using the terms workbook and worksheet in this manual. 

The MS Excel 2010 window 

First introduced in MS Office 2007, the ribbon makes it easy for you to find commands and features 

that were previously buried in complex menus and toolbars.  The new design in Microsoft Office 2010 

has seen the File tab replacing the MS Office Button included in 2007 Office applications. 

When you click the File tab in Excel 2010, you see the same basic commands that were 

available after you clicked the Microsoft Office Button or the File menu in Excel 2007.  

These basic commands include, but are not limited to, Open, Save and Print.  Some commands, such as 

Import, have been moved to the ribbon in Excel 2010. 
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In the Excel 2010 window the title bar displays the name of your current workbook. Tabs at the bottom 

of the screen identify the different worksheets available to you - I’ll show you a little later how to give 

them meaningful names. 

 

 
Notice how the working area of the screen is divided into rows (1, 2, 3, 4, ...) and columns (A, B, C, 

D, …). Together these provide an address, such a C10 or G21, that uniquely identifies each cell in the 

worksheet. A range of cells extends in a rectangle from one cell to another, and is referred to by using 

the first and last cell addresses separated by a colon. 

For example, the group of cells from A3 to G4 would be written as A3:G4 

In the example above, the current or active cell is B7. It is surrounded by a heavy black border, and its 

address is displayed in the name box above column A. Its row and column numbers are also 

highlighted. 

On the right of the name box is the Formula bar. This displays the value stored in the active cell, and is 

also the place where you would enter a new data value or formula into that cell. 

 

Title bar Ribbon tabs 

File 
menu Window controls 

Quick access 
toolbar 

Active 
cell 

Formula bar 

Worksheets Status 
bar 

Zoom slider 
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Starting MS Excel 

If you have an icon on the desktop for MS Excel, then all you have to do is double-click 

it to open Excel.  

Alternatively, click the Start button and then select: 

All Programs > Microsoft Office > Microsoft Excel 

 

 

 When you open Excel from a desktop icon or from the Start menu, a new empty workbook 

(consisting of three worksheets) will be displayed on your screen. 

 If you double-click on an existing Excel file from inside the Windows Explorer window, then 

Excel will open and display the selected file on your screen. 

 

Closing MS Excel 

You can close Excel by clicking the X on the far right of the title bar or by 

selecting File > Exit. If you have unsaved data you will be prompted to save the changes before exiting. 

Navigating within a worksheet 

Using the mouse: 

 Use the vertical and horizontal scroll bars if you want to move to an area of the screen that is 

not currently visible. 

 To move to a different worksheet, just click on the tab below the worksheet. 

Using the keyboard: 

 Use the arrow keys, or [PAGE UP] and [PAGE DOWN], to move to a different area of the screen. 

 [CTRL] + [HOME} will take you to cell A1. 

 [CTRL] + [PAGE DOWN] will take you to the next worksheet, or use [CTRL] + [PAGE UP] for the 

preceding worksheet. 

You can jump quickly to a specific cell by pressing [F5] and typing in the cell address. You can also type 

the cell address in the name box above column A, and press [ENTER]. 
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Selecting cells 

Using the mouse: 

 Click on a cell to select it. 

 You can select a range of adjacent cells by clicking on the first one, and then dragging the 

mouse over the others. 

 You can select a set of non-adjacent cells by clicking on the first one, and then holding down 

the [CTRL] key as you click on the others. 

Using the keyboard: 

 Use the arrow keys to move to the desired cell, which is automatically selected. 

 To select multiple cells, hold down the [SHIFT] key while the first cell is active, and then use the 

arrow keys to select the rest of the range. 

Selecting rows or columns 

To select all the cells in a particular row, just click on the row number (1, 2, 3, etc.) at the left edge of 

the worksheet. Hold down the mouse button and drag across row numbers to select multiple adjacent 

rows. Hold down [CTRL] if you want to select a set of non-adjacent rows. 

Similarly, to select all the cells in column, you should click on the column heading (A, B, C, etc.) at the 

top edge of the worksheet. Hold down the mouse button and drag across column headings to select 

multiple adjacent columns. Hold down [CTRL] if you want to select a set of non-adjacent columns. 

You can quickly select all the cells in a worksheet by clicking the square to the immediate left of the 

Column A heading (just above the label for Row 1). 

 
To select the entire worksheet you can also press [CTRL] + [A]. 

Note: If the worksheet contains data, [CTRL] + [A] selects the current region. Pressing [CTRL] + [A] a 

second time selects the entire worksheet. 
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Entering data 

First you need a workbook 

Before you start entering data, you need to decide whether this is a completely new project deserving 

a workbook of its own, or whether the data you are going to enter relates to an existing workbook. 

Remember that you can always add a new worksheet to an existing workbook, and you’ll find it much 

easier to work with related data if it’s all stored in the same file. 

If you need to create a new workbook from inside Excel: 

1. Click on the File tab, select New and then double click Blank workbook. 

2. Sheet1 of a new workbook will be displayed on your screen, with cell A1 active. 

To open an existing workbook from inside Excel: 

1. Click on the File tab, click Open, and then navigate to the drive and folder containing the file 

you want to open. 

2. Double-click on the required file name. 

Overview of data types 

Excel allows you to enter different sorts of data into the cells on a worksheet, such as dates, text, and 

numbers. If you understand how Excel treats the different types of data, you’ll be able to structure 

your worksheet as efficiently as possible. 

 Numbers lie at the heart of Excel’s functionality. They can be formatted in a variety of different 

ways – we’ll get to that later. You should generally avoid mixing text and numbers in a single 

cell, since Excel will regard the cell contents as text, and won’t include the embedded number 

in calculations. If you type any spaces within a number, it will also be regarded as text. 

 

   

   

 

Note that dates and times are stored as numbers in Excel, so that you can calculate the 

difference between two dates. However, they are usually displayed as if they are text. 

If a number is too large to be displayed in the current cell, it will be displayed as “#######”.  

The formatting section of this manual explains how to widen a column. 

 Text consists mainly of alphabetic characters, but can also include numbers, punctuation marks 

and special characters (like the check mark in the example above). Text fields are not included 

in numeric calculations. If you want Excel to treat a number as text, then you should precede 

the number with a single quotation mark (‘). This can be useful when entering for example a 

phone number that starts with 0, since leading zeros are not displayed for Excel numbers. 

If a text field is too long to be displayed in the current cell, it will spill over into the next cell if 

that cell is empty, otherwise it will be truncated at the cell border. The formatting section of 

this manual explains how to wrap text within a cell. 
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 Formulas are the most powerful elements of an Excel spreadsheet. Every formula starts with 

an “=” sign, and contains at least one logical or mathematical operation (or special function), 

combined with numbers and/or cell references. We’ll discuss formulas and functions in more 

detail later in the manual. 

Data entry cell by cell 

To enter either numbers or text: 

1. Click on the cell where you want the data to be stored, so that the cell becomes active. 

2. Type the number or text. 

3. Press [ENTER] to move to the next row, or [TAB] to move to the next column. 

Until you’ve pressed [ENTER] or [TAB], you can cancel the data entry by pressing [ESC]. 

To enter a date, use a slash or hyphen between the day, month and year, for example 14/02/2009 

Use a colon between hours, minutes and seconds, for example 13:45:20 

Remember that useful Undo button on the Quick access toolbar! 

Deleting data 

You want to delete data that’s already been entered in a worksheet? Simple! 

1. Select the cell or cells containing data to be deleted. 

2. Press the [DELETE] key on your keyboard. 

3. The cells remain in the same position as before, but their contents are deleted. 

Moving data 

You’ve already entered some data, and want to move it to a different area on the worksheet? 

1. Select the cells you want to move (they will become highlighted). 

2. Move the cursor to the border of the highlighted cells. When the cursor changes  

from a white cross to a four-headed arrow (the move pointer), hold down the  

left mouse button.  

3. Drag the selected cells to a new area of the worksheet, then release the mouse button. 

You can also cut the selected data using the cut option on the Home tab or [CTRL] + [X]. Then click in 

the top left cell of the destination area and paste the data with paste option or [CTRL] + [V]. 

Copying data 

To copy existing cell contents to another area on the worksheet: 

1. Select the cells you want to copy (they will become highlighted). 

2. Move the cursor to the border of the highlighted cells while holding down the  

[CTRL] key.  When the cursor changes from a white cross to a hollow left-pointing 

arrow (the copy pointer), hold down the left mouse button. 

3. Drag the selected cells to a second area of the worksheet, then release the mouse button. 
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You can also copy the selected data using the copy option on the Home tab or [CTRL] + [C]. Then click 

in the top left cell of the destination area and paste the data with the paste option or 

[CTRL] + [V]. 

To copy the contents of one cell to a set of adjacent cells, select the initial cell and then 

move the cursor over the small square in the bottom right-hand corner (the fill handle). 

The cursor will change from a white cross   to a black cross .  Hold down the mouse button and 

drag to a range of adjacent cells. The initial cell contents will be copied to the other cells. Note that if 

the original cell contents end with a number, then the number will be incremented in the copied cells. 

If the original cell that you are moving or copying contains a reference to a cell address, then the 

copied cell address will be adjusted relative to the target cell.  Refer to Formulas – Referencing later in 

this manual for details. 

Using AutoFill 

This is one of Excel’s niftiest features! It takes no effort at all to repeat a data series (such as the days 

of the week, months of the year, or a numbers series such as odd numbers) over a range of cells. 

1. Enter the start of the series into a few adjacent cells (enough to show the underlying pattern). 

2. Select the cells that contain series data. 

3. Move the cursor over the small square in the bottom right-hand corner of the selection (the 

fill handle). Hold down the mouse button and drag to a range of adjacent cells. 

4. The target cells will be filled based on the pattern of the original series cells. 

Saving a workbook 

So now it’s time to save your work. As usual, you need to specify the file name, and its location (drive 

and folder). 

1. Click the File menu and select Save, or click the Save icon on the Quick Access toolbar. 

If this workbook has been saved before, then that’s it – your workbook will be saved again with 

the same name and location. 

2. If it’s the first time of saving this workbook, then the Save As dialogue box will open. 

3. Click the drop-down arrow next to Save In to select the desired drive and folder. 

4. Type the new file name in the File name field. 

5. Click the Save button. 

 

Every time you Save or Save As in Excel, the entire workbook is saved. This is another good reason for 

keeping related data on different worksheets in the same workbook! When you’re working in the UCT 

computer labs, remember to save to the F: drive, so that you’ll be able to access your work again later. 
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Editing data 
In data entry mode, when you move the cursor to a new cell, anything you type replaces the previous 

cell contents. Edit mode allow you to amend existing cell contents without having to retype the entire 

entry. Note that while you are in edit mode, many of the Ribbon commands are disabled. 

Editing cell contents 

There are two different ways to enter edit mode: either double-click on the cell whose contents you 

want to edit, or else click to select the cell you want to edit, and then click anywhere in the formula 

bar. 

 To delete characters, use the [BACKSPACE] or [DELETE] key. 

 To insert characters, click where you want to insert them, and then type. 

You can toggle between insert and overtype mode by pressing the [INSERT] key. 

 You can force a line break within the current cell contents by typing [ALT] + [ENTER]. 

Exit edit mode by pressing [ENTER]. 

Your cell contents look correct in the formula bar, but don’t display correctly in the worksheet? Check 

whether either of these common problems is the culprit: 

  If a cell contains a number but displays #####, then the column is not wide enough to show the full 
data value. You need to make the column wider (see formatting). 

  If a cell contains text but chops off the display at the edge of the column, then you need to either 
widen the column or wrap the text within the column (see formatting). 

Inserting or deleting cells 

You can insert a new cell above the current active cell, in which case the active 

cell and those below it will each move down one row.  You can also insert a new 

cell to the left of the current active cell, in which case the active cell and those 

on its right will each move one column to the right. 

To insert a cell: 

1. Select the cell next to which you want to insert a new cell. 

2. On the Home Tab, find the Cells group and click Insert followed by Insert Cells. 

 
3. A dialog box will open. Click the direction in which you want the surrounding cells to shift. 
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To delete a cell, do as follows: 

1. Select the cell that you want to delete. 

2. On the Home tab, find the Cells group and click Delete followed by Delete Cells. 

 
3. A dialog box will open. Click the direction in which you want the surrounding cells to shift. 

You can also right-click on the active cell and select Insert or Delete on the pop-up menu. 

Inserting or deleting rows 

When you insert a row, the new row will be positioned above the row containing the active cell. 

1. Select a cell in the row above which you want to insert a new row. 

2. On the Home tab, find the Cells group and click Insert followed by Insert Sheet Rows. 

3. A new row will be inserted above the current row. 

To delete a row, do as follows: 

1. Select a cell in the row that you want to delete. 

2. On the Home tab, find the Cells group and click Delete followed by Delete Sheet Rows. 

3. The row containing the active cell will be deleted. All the rows below it will move up by one. 

You can also right-click on the active cell and use the pop-up menu to insert or delete a row. 

Inserting or deleting columns 

When you insert a column, the new column will be positioned on the left of the column containing the 

active cell. 
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1. Select a cell in the column to the left of which you want to insert a new column. 

2. On the Home tab, find the Cells group and click Insert followed by Insert Sheet Columns. 

3. A new column will be inserted to the left of the current column. 

To delete a column, do as follows: 

1. Select a cell in the column that you want to delete. 

2. On the Home tab, find the Cells group and click Delete followed by Delete Sheet Columns. 

3. The column containing the active cell will be deleted. All the columns on its right will move left 

by one. 

You can also right-click on the active cell and use the pop-up menu to insert or delete a column. 

Inserting or deleting a worksheet 

To insert a new worksheet at the end of the existing worksheets, just click the Insert Worksheet tab at 

the bottom of the screen.  The shortcut key to do this is [SHIFT] + [F11]. 

 
To insert a new worksheet before an existing worksheet, do as follows: 

1. Select the worksheet before which you want to insert a new worksheet. 

2. On the Home tab, find the Cells group and click Insert followed by Insert Sheet. 

3. A new worksheet will be inserted before the current worksheet. 

To delete a worksheet: 

1. Select the worksheet that you want to delete. 

2. On the Home tab, find the Cells group and click Delete followed by Delete Sheet. 

3. The current worksheet will be deleted. 

Moving or copying a worksheet 

Right-click on the worksheet tab, and select Move or Copy from the pop-up menu. A dialog box will 

open: 
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The To book field allows you to move or copy the current worksheet to another workbook. 

The Before sheet field allows you to specify the new position of the worksheet. 

The Create a copy checkbox lets you specify whether the worksheet should be moved or copied. 

 

Renaming a worksheet 

Right-click on the worksheet tab, and select Rename from the pop-up 

menu. Type the new worksheet name and press [ENTER]. 

 
 
 
 
 
 
 
 

  

The simplest way to insert, delete, rename, move or copy a 

worksheet is to right-click on the worksheet tab, and then select 

the desired option from the pop-up menu. 
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Formatting data 

Cell formatting 

The icons on the Home tab provide you with a variety of formatting options. To apply any of these, just 

select the cell or cells that you want to format, and then click the desired icon. 

Commonly used formatting attributes include: 

 
Font and Size 

 
Bold, Italic, Underline 

 
Cell borders 

 
Background and Font colour 

 
Alignment: Left, Centre or Right 

 
Merge and centre text across multiple cells 

 
Wrap text within a cell 

 
Rotate angle of text 

 
Format number as Currency, Percentage or Decimal 

 
Increase or Decrease number of decimal places 

 
The Format Painter allows you to copy formatting attributes from one cell to a range of cells. 

1. Select the cell whose formatting attributes you want to copy. 

2. Click on the Format Painter icon. 

3. Select the cell or range of cells that you want to have the same formatting attributes. 

The cell values will remain as before, but their format will change. 

Formatting rows and columns  

Any of the cell formatting options above can easily be applied to all the cells contained in one or more 

rows or columns. Simply select the rows or columns by clicking on the row or column labels, and then 

click on the formatting icons that you want to apply. 

You may also want to adjust the width of a column: 

 To manually adjust the width, click and drag the boundary 

between two column headings. 

 To automatically adjust the width, select the required columns, and then in the Cell group on 

the Home tab, select Format > Cell Size > AutoFit Column Width 
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 To specify an exact column width, select the columns, and then in the Cell group on the Home 

tab, select Format > Cell Size > Column Width, and type the value you want. 

 
To adjust the height of a row: 

 To manually adjust the height, click and drag the boundary between two row labels. 

 To automatically adjust the height, select the required rows, and then in the Cell group on the 

Home tab, select Format > Cell Size > AutoFit Row Height 

 To set a row or rows to a specific height, select the rows, and then in the Cell group on the 

Home tab, select Format > Cell Size > Row Height, and type the value that you want. 

Hiding rows and columns 

If your spreadsheet contains sensitive data that you don’t want displayed on the screen or included in 

printouts, then you can hide the corresponding rows or columns. The cell values can still be used for 

calculations, but will be hidden from view. 

 

The easiest way to hide or unhide a row or column is to: 

 Select the row or column heading 

 Right-click to view the pop-up menu 

 Then select Hide or Unhide. 

 



Introduction to MS Excel 2010 Page 17 

 

2011 Centre for Educational Technology, University of Cape Town 

Alternatively, on the Home tab you can click the Format and select the Hide & Unhide option. 

 

 
 
 
 
 

Keeping row and column headings in view 

If you scroll through a lot of data in a worksheet, you’ll probably lose sight of the column headings as 

they disappear off the top of your “page”. This can make life really difficult – imagine trying to check a 

student’s result for tutorial 8 in row 183 of the worksheet!  And it’s even more difficult if the student’s 

name in column A has scrolled off the left edge of the window. 

The Freeze Panes feature allows you to specify particular rows and columns that will always remain 

visible as you scroll through the worksheet. And it’s easy to do! 

Select a cell immediately below the rows that you want to remain visible, and immediately to the right 

of the columns that you want to remain visible. 

For example, if you want to be able to see Rows 1 and 2, and column A, then you would click on cell B3. 

 
 

On the View tab, click Freeze Panes, and 

select the first option. 

 
If Freeze Panes has already been 

applied, then the option automatically 

changes to Unfreeze Panes. 
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Formulas 
Formulas are the key to Excel’s amazing power and versatility! By using a formula, you can find the 

answer to virtually any calculation you can think of! In this section I’m going to explain how to 

construct a formula, and give you some guidelines to ensure that your formulas work correctly. 

Creating a formula 

Rule number one: a formula always starts with an equals sign (“=”). This lets Excel know that it’s going 

to have to work something out. 

In the body of the formula, you’re going to tell Excel what you want it to calculate. You can use all the 

standard maths operations, like addition and multiplication, and you can include numbers, cell 

references, or built in functions (which are covered in the next section of this manual). 

For example, suppose you have a retail business. You buy stock at cost price, and add a 25% markup to 

calculate your selling price. VAT must be added to that at 14%. You give a 5% discount to long-standing 

customers who pay their accounts promptly. Let’s look at how formulas can make the calculations 

simple for you: 

 

 In column A, the Stock item labels have just been typed in. 

 In column B, the Cost price values have just been typed in. 

 In column C, I’ve used a formula. Cell C2 contains “=B2 * 25%”. This works out 25% of the value 

in cell B2 (Cost price), and displays the result in cell C2 (Markup). 

 In column D, I’ve used a formula. Cell D2 contains “=B2 + C2”. This adds the values in cells B2 

(Cost price) and C2 (Markup), and displays the result in cell D2 (Retail price). 

 In column E, I’ve used a formula. Cell E2 contains “=D2 * 14%”. This works out 14% of the value 

in cell D2 (Retail price), and displays the result in cell E2 (VAT). 

 In column F, I’ve used a formula. Perhaps by now you can work it out for yourself? Cell F2 

contains “=D2 + E2”. This adds the values in cells D2 (Retail price) and E2 (VAT), and displays 

the result in cell F2 (Selling price). 

 In column G, I’ve used a formula. Cell G2 contains “=F2 * 95%”. This works out 95% of the value 

in cell F2 (Selling price), and displays the result in cell G2 (Discounted price). 

And the great thing about using formulas in Excel, is that you can copy them just as you do values.  So 

once you’ve entered all the formulas in row 2 and checked that they are correct, you just need to: 

1. Select the cells in row 2 that contain your formulas (cells C2 to G2). 
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2. Move the cursor over the fill handle in the bottom right corner of the selected cells. 

It will change shape to a black cross. 

3. Hold down the mouse button and drag the selected cells over rows 3 to 5. 

The values in cells C3 to G5 are automatically calculated for you! How cool is that? 

How formulas are evaluated 

Now let’s look at some of the rules for creating formulas. 

The operators that you need to know are: 

+ addition 

– subtraction 

* multiplication 

/ division 

^ exponentiation (“to the power of”) 

& to join two text strings together 

These operations are evaluated in a particular order of precedence by Excel: 

 Operations inside brackets are calculated first 

 Exponentiation is calculated second. 

 Multiplication and division are calculated third. 

 Addition and subtraction are calculated fourth. 

 When you have several items at the same level of precedence, they are calculated from left to 

right. 

Let’s look at some examples: 

= 10 + 5 * 3 – 7   (result: 10 + 15 – 7 = 18) 

= (10 + 5) * 3 – 7 (result: 15 * 3 – 7 = 38) 

= (10 + 5) * (3 – 7) (result: 15 * -4 = -60) 

If you’re not sure how a formula will be evaluated - use brackets! 

Relative cell referencing 

Remember in the pricing example above, how you just had to copy the formulas in row 2 and the 

remaining values were automatically calculated? 

Look again in the formula bar of that screenshot. Although the formula that you copied from cell G2 

was “=F2 * 95%”, the formula in cell G5 reads “=F5 * 95%”. The original reference to row 2 in the 

formula has changed to a reference to row 5. This is called relative addressing, and it’s an important 

concept. 
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Relative addressing is what Excel uses by default. This means that when you copy or move a formula to 

a new location in a worksheet (or even to another workbook), Excel automatically adjusts the cell 

references in the copied formula to be consistent with the original formula. If the original formula 

referenced a value five columns to the left and two rows down, then the copied formula will do the 

same. 

Does this concept make sense? If not, then give it some careful thought, because it’s important that 

you understand it. 

Absolute cell referencing 

Now we’re going to improve the structure and usability of our pricing model. After all, there’s no 

guarantee that your markup will always be 25% - in these tough economic times you may need to 

reduce it to remain competitive. And what if the VAT rate changes? Or maybe you decide to increase 

the discount to encourage customers to pay promptly? 

The following example shows you how to construct the worksheet so that it allows for future changes. 

 
Here I’ve made life a lot easier for myself by showing the Markup rate, VAT rate and Discount rate, in 

cells A1 to B3. I no longer have to remember what values I used in my formulas – I can just look at the 

top of the worksheet. 

Now my formulas need to change, so that they refer to the values in cells B1 to B3 instead of physically 

typing the actual percentages in each formula. 

 The formula in cell C5 will become “=B5 * B1”, instead of the previous “=B5 * 25%”. 

This multiplies the value in cell B5 (Cost price) by the value in cell B1 (Markup rate), and 

displays the result in cell C5 (Markup). 

 The formula in cell E5 will become contains “=D5 * B2”, instead of the previous “=D5 * 14%”. 

This multiplies the value in cell D5 (Retail price) by the value in cell B2 (VAT rate), and displays 

the result in cell E5 (Selling price). 

Check that you follow the logic so far. If not, please go through it again. 

BUT … Stop right here! Do you see the problem ahead? 

When I copy my new formulas from row 5 into rows 6 to 8, Excel is going to use relative addressing. 

The formula in cell C5 refers to cell B1 (Markup rate). When I copy the formula to the next row, it will 

want to refer to cell B2 (VAT rate), instead of cell B1 (Markup rate). 

By the time I’ve finished copying, my spreadsheet will look like this: 
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Clearly something is very wrong! 

Relative addressing makes working with formulas really easy, but sometimes you don’t want the 

referencing in the formula to change as the formula is copied. Then you need to use absolute 

addressing. Absolute addressing fixes a cell reference so that regardless of where the formula is copied 

to, it will always reference the same original cell. This feature takes the versatility of formulas to the 

next level! 

To use absolute addressing in a formula, all you need do is to click on the cell reference that you want 

to remain fixed, and then press the [F4] key. Take for example the formula in cell C5: 

Using relative addressing, the formula looked like this: = B5 * B1 

1. Double click on cell C5 to enter edit mode. 

2. In the formula bar, click on the cell reference “B1” and press [F4] on the keyboard. 

3. The formula changes to: =B5 * $B$1. Note that cell reference B5 must retain its relative 

addressing, since you want to multiply each different cost price by the same fixed Markup rate. 

4. Press [ENTER] to accept the change. 

Instead of using the [F4] key to make a cell reference absolute, you can simply type the dollar signs if 

you prefer to do so. 

Once all the formulas in row 5 have been corrected to use absolute referencing, you can copy them 

into rows 6 to 8. The following screenshot shows the result – now it all works perfectly! 

 
Any future changes to the Markup rate, VAT rate or Discount rate need only be entered once in cells 

B1 to B3 (where they are clearly visible), and the calculated values from Row 5 downwards will 

automatically be updated! 
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Functions 
Excel provides a wide range of built-in functions that can be included in your formulas to save you the 

effort of having to specify detailed calculations step-by-step. Each function is referred to by a specific 

name, which acts as a kind of shorthand for the underlying calculation. 

Because a function is used inside a formula, you’ll still need to start off with an equals sign to show 

Excel that a calculation is required. 

Using AutoSum 

Because addition is the most frequently used Excel function, a shortcut has been provided to quickly 

add a set of numbers: 

1. Select the cell where you want the total to appear. 

2. Click on the AutoSum button on the Home tab.  

3. Check that the correct set of numbers has been selected (indicated by a dotted line). 

If not, then drag to select a different set of numbers. 

4. Press [ENTER] and the total will be calculated. 

Basic functions 

Some of the most commonly used functions include: 

SUM( )  to calculate the total of a set of numbers 

AVERAGE( ) to calculate the average of a set of numbers 

MAX( )  to calculate the maximum value within a set of numbers 

MIN( )  to calculate the minimum value within a set of numbers 

ROUND( ) to round a set a values to a specified number of decimal places 

TODAY ( ) to show the current date 

IF( )  to calculate a result depending on one or more conditions 

So how do you use a function? 

A function makes use of values or cell references, just like a simple formula does. The numbers or cell 

references that it needs for its calculations are placed in brackets after the name of the function. 

To give a simple illustration: 

The formula: Is equivalent to the function: 

= 12 + 195 + 67 – 43 = SUM(12, 195, 67, -43) 

= (B3 + B4 + B5 + B6) =SUM(B3:B6) 

= (B3 + B4 + B5 + B6)/4 = AVERAGE (B3:B6) 
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Several popular functions are available to you directly from the Home tab. 

1. Select the cell where you want the result of the calculation to 

be displayed. 

2. Click the drop-down arrow next to the AutoSum button. 

3. Click on the function that you want. 

4. Confirm the range of cells that the function should use in its 

calculation. (Excel will try to guess this for you. If you don’t 

like what it shows inside the dotted line, then click and drag 

to make your own selection.) 

5. Press [ENTER]. The result of the calculation will be shown in 

the active cell. 

As an example, to calculate the average for the following set of tutorial results, you would: 

1. Click on cell F3 to make it active. 

Click on the arrow next to the AutoSum button, and select Average 

2. Press [ENTER] to accept the range of cells that is suggested (B3:E3) 

That’s it! You can now copy the formula in cell F3 down to cells F4 and F5 – using relative addressing 

because you want a different set of tutorial marks to be used for each student. 

 
If you want to use a function that isn’t directly available from the drop-down list, then you can click on 

More Functions to open the Insert Function dialog box. Another way to open this dialog box is to click 

the Insert Function icon on the immediate left of the formula bar. 

The Insert Function dialog box displays a list of functions within a selected function category. If you 

select a function it will briefly describe the purpose and structure of the function. 
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When you click the OK button at the bottom of the window, you’ll be taken to a second dialogue box 

that helps you to select the Function Arguments (usually the range of cells that the function should 

use). 

 
Some functions use more than one argument. For example, the ROUND( ) function needs to know not 

only which cells to use, but also how many decimal places those cells should be rounded to. So the 

expression =ROUND(G5:G8, 0) will round the values in cells G5 to G8 to the nearest whole number (i.e. 

no decimal places). 

Note that the ROUND( ) function actually changes the value that is stored in your worksheet, based on 

the arguments you’ve provided. Formatting options such as Currency, or Increase / Decrease Decimal, 

simply change the appearance of a number, but all its decimal places are still kept, and displayed in the 

formula bar. 
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The IF( ) function 

The IF( ) function is getting a section all of its own, because for many people it’s not as intuitive to 

understand as the common maths and stats functions. 

The IF( ) function checks for a specific condition. If the condition is met, then one action is taken; if the 

condition is not met, then a different action is taken. For example, you may be reviewing a set of 

tutorial marks. If a student’s average mark is below 50, then the cell value should be FAIL; so the 

condition you are checking is whether or not the average result is below 50. If this condition is not met 

(that is, the average result is 50 or more), then the cell value should be PASS. 

Let’s see this in action.  The structure of an IF( ) function is: 

 =IF (condition, result if true, result if false) 

Using English to describe our example as an IF statement:  IF the average mark is less than 50, then 

display the word “FAIL”, else display the word “PASS”. 

Now for a real worksheet example. Look at the formula bar in the screenshot below: 

 
Do you follow how the formula in cell G4 was constructed? Because the average mark is stored in cell 

F4, we need to check whether the value in F4 is less than 50. If it is, then the active cell (G4) must 

display the word “Fail”. If the value in F4 is not less than 50, then the active cell must display the word 

“Pass”. That’s not really so complicated, is it? 

Nested functions 

Take a deep breath and don’t panic! I just want to show you that if you need to, you can include one 

function inside another. 

In the example above, we first worked out the Average mark, and then the Pass/Fail outcome. But we 

could have done it all in a single step, by using the following formula in row 3: 

=IF(AVERAGE(B3:E3) < 50, “FAIL”, “PASS”) 

In this IF statement, I’ve nested one function inside another. The reference to cell F4 has been replaced 

with a function that calculates the average tutorial mark, and then checks it against the same condition 

as before (“< 50”), with the same possible outcomes. Doing it this way, you wouldn’t need column F in 

the worksheet at all, although you would probably want to keep the Average column in order to 

explain the outcome to students if they come to query their mark. So the first example using a 

separate Average and a basic IF statement is not only simpler, it’s also more practical! 
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Printing 
By default, Excel prints all the data on the current worksheet. If your worksheet extends over several 

pages, it’s worth making sure that the printed copy will be easily readable. Here are a few tips. 

Before you print 

Before you print a worksheet that contains large quantities of data or charts, you can quickly fine-tune 

the worksheet in the Page Layout view. 

 
 Use the Orientation button to swap between portrait and landscape mode. 

 Use the Print Area button to select a subset of your data for printing. (The data that you want 

included in the print area should be selected before you click this icon.) 

 Use the Breaks button to insert a page break immediately above the currently active cell, or to 

remove previously specified page breaks. 

 The Print Titles button takes you to the Page Setup dialogue box, which has four tabs that 

allow you to do a whole lot more than printing titles. 

 
 The Page tab is used to set orientation and scaling. 

 The Margins tab is used to adjust page margins. 

 The Header/Footer tab allows you to enter a header or footer to be repeated on every 

page. This is where you would include page numbers using custom headers and footers. 

 The Sheet tab lets you specify rows that are to be repeated at the top of each sheet (such 

as column headings), and columns to be repeated at the left of each sheet (such as student 

names). You can also adjust the print area under this tab. 
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Print Preview 

To print your worksheet click the File tab and then Print. The display will change to Print Preview mode 

and you will see your data exactly as it will look when printed. 

 
Before you print, there are a number of options that you can select. Changing any option automatically 

updates the live preview, on the right of the screen, showing the effect of the change. 

 If you’d like multiple copies of the worksheet, enter the number of copies in the Copies field. 

 If you have more than one printer to choose from, they will be available in the Printer section. 

Click the drop-down arrow next to the current printer name to select your preferred printer. 

 Would you like to print selected pages only? In the Settings section you can choose to only 

print the active sheets, print the entire workbook or only print the current selection. 

 You can enter the page numbers that you’d like printed in the Pages field, or just leave the 

fields blank if you want all pages printed. 

 The settings section also allows you to set the Page Orientation, select the Paper Size, set the 

Margins and customise the scaling options. 

When you’re satisfied with your settings click the Print button.  The specified 

worksheet pages will then be sent to the printer. 

If you do not want to print then you can click the Home tab and you will be 

returned to the worksheet. 
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Charts 
A picture is worth a thousand words! Often it’s much easier to understand data when it’s presented 

graphically, and Excel provides the perfect tools to do this! 

It’s worth starting with a quick outline of different data types and charts: 

Categorical data items belong to separate conceptual categories such as knives, forks and spoons; or 

males and females. They don’t have inherent numerical values, and it doesn’t make sense to do 

calculations such as finding an average category. A pie chart or column chart is most suitable for 

categorical data. 

Discrete data items have numerical values associated with them, but only whole values; for example, 

the number of TV sets in a household. Again, average values don’t make much sense. Discrete 

data is often grouped in categories (“less than three”, “four or more”) and treated as categorical 

data. 

Continuous data refers to numerical values that have an infinite number of possible values, limited 

only by the form of measurement used. Examples are rainfall, temperature, time. Where discrete 

data has a very large number of possible values, it may also be treated as continuous. Continuous 

data is well suited to line graphs, which are very useful for illustrating trends. 

Of course, Excel offers you many more chart types than just these three. Do remember that it’s best to 

select a chart type based on what you’re trying to communicate. 

 
 

Creating a chart 

It’s very easy to create a basic chart in MS Excel 2010: 

1. Select the data that you want to include in the chart (together with column headings if you 

have them(. 

2. On the Insert tab, find the Charts group and select your preferred chart type. 

 

3. That’s it! The chart appears in the current window. Move the cursor over the chart area and 

drag it to a new position. 

 

Excel Help  has a lot of useful information. Look under Charts in the Table of Contents. 
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Modifying a chart 

When you click on a chart, a Chart Tools section appears with Design, Layout and Format tabs.  

 
In the example below, I’ve used different options to change the chart type to Column and swapped the 

rows and columns. All it took was four mouse clicks! 
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On the Chart Tools menu: 

 Use the Design tab to quickly change the chart type, or to swap data rows and columns. 

 Use the Layout tab to add a title, and to provide axis and data labels. 

 Use the Format tab to add border and fill effects. 

Inserting graphics in a worksheet 

Sometimes you may want to add graphics, for example a corporate logo, to a worksheet. The good 

news is that images, ClipArt and SmartArt are available in Excel, along with a host of call-out shapes 

that you can use to label your charts. You’ll find them all on the Insert tab: 

 
Below I’ve added a Rectangular Callout Shape to highlight the top student: 
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Data manipulation 
The features mentioned in this section are most relevant when you’re working with a large data set – 

perhaps several hundred, or even thousand records – and it isn’t practical to scroll through the entire 

worksheet each time you want to find a particular record. 

To use data functions effectively, each column of your worksheet should contain the same data type, 

apart from the column heading. Ideally, row 1 should contain the column headings, with the data rows 

immediately below; this structure is referred to as a data table. If you have blank rows in your data set, 

then you’ll need to manually select the data to be manipulated, which you don’t really want to do. 

Sort 

The sort function does exactly what it says: it sorts your data records based on the criteria that you 

specify. You can sort numbers, text or dates, in either ascending (default) or descending order. Blank 

cells are always placed last in a sort. 

If you want to sort an entire data table: 

1. Click anywhere in the column that you want to sort by. 

2. On the Home tab, select Sort & Filter. 

3. Choose either Ascending (Sort A to Z) or Descending (Sort Z to A) 

order. 

4. Your data will be sorted based on the value in the column that 

you initially clicked on. 

If you want to sort on two or more criteria (columns), or if you want to 

sort a range of cells, then you need to do a custom sort: 

1. Click in the data table, or select the cells to be sorted. 

2. On the Home tab, select Sort & Filter, and choose Custom Sort. The Sort Window will open. 

 

3. In the Sort by field, use the drop-down arrows to select the column that you want to sort by 

and the order (ascending or descending) to be used. 
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4. If you want to add another sort criterion, then click the Add Level button, and a second details 

row will appear in the window. Again, choose the sort column and sort order. 

5. Add more levels (or Delete Level) as required. 

6. When you click the OK button at the bottom of the window, your data will be sorted. 

Note that the Sort function is also available from the Data tab. 

Remember that you can rely on the Undo button if you don’t like the result that you get! 

Filter 

The filter function lets you view just the records that you want to see! The other records in your data 

table will still be there, but hidden. To use this amazing function: 

1. On the Home tab, select Sort & Filter, and select the Filter option. 

2. In the first row of your data table, a drop-down arrow will appear on the right of each column 

heading. When you click on a drop-down arrow, you’ll see a list of all the values occurring in 

that column. Press [ESC] to close the filter list. 

 
3. If you want to view records with a particular value only, click to uncheck the Select All option, 

and then check one or more values that you want to view. Click the OK button. (The example 

above has already been filtered on Product, Delivery month and Customer Type, and is about 

to be filtered on Discount as well.) 

4. All rows that do not contain the value(s) you checked, will be hidden from view. A column that 

has been filtered will show a funnel icon next to the drop-down arrow on the heading. 

5. Repeat the filtering process for as many columns as you need. You can remove a column filter 

by checking its Select All option. 

To clear your previous filter settings, select Sort & Filter, and then Clear. 

To turn off filtering, select Sort & Filter, and then Filter 

- the same option that you originally used to turn it on. 
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Note that the Sort function is also available from the Data tab. 

Subtotals 

You can automatically calculate subtotals and grand totals in a list for a column by using the Subtotal 

command. If your data table includes a column with categorical data (such as month, department, 

region, etc.), then you can easily obtain subtotals of numeric values (such as sales, salaries, rainfall) 

without having to manually create the formulas. 

To insert Subtotals: 

1. First sort your data on the column that contains categorical data for which you want subtotals 

calculated. 

2. On the Data tab in the Outline group, click the Subtotal button. 

 
The Subtotal window will appear. 

 

3. In the At each change in field, select the column with categorical data that was used for 

sorting. 

4. The Use function field allows you to choose from a range of functions such as Sum, Count, 

Average, Max, Min, Product. 
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5. Use the Add subtotal to checkboxes to identify the columns for which you want subtotals to be 

calculated. 

6. Click the OK button.  The screen display will show three outline levels on the left of the data 

window. 

 Level 1 shows the overall grand total only. Click on the  icon or on the level 2 button to 

see subtotals. 

 
 Level 2 shows the requested subtotals only. Click on the  icon to see the records within 

one category, or click on the level 3 button to see all records. 

 

To remove subtotals: 

 On the Data tab in the Outline group click Subtotal, then click Remove All. 
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MS Excel Practical Exercise 
 

 

 

 

 
Enter the following data into a blank worksheet: 

 
Now follow the instructions below, referring to the example worksheet on the following page. 

1. 
Select the entire worksheet, and change the font to Calibri 11 point. 
If you don’t have Calibri available, then choose another font. 

2. In row 1, make the headings Bold and 12 point. 

3. In column B, make the text Italic. 

4. Give column D the heading:  Annual Salary 

5. In cell D2, use a formula to calculate the annual salary for Sophia Adams. 

6. Copy the formula in cell D2 into rows 3 to 11. 

7. In cell A13, enter the text:  Suggested Increase 

8. In cell B13, enter the value 6% and make it left-aligned. 

9. Give column E the heading:  Salary Increase 

10. 
In cell E2, enter a formula that will calculate the suggested annual increase for 
Sophia Adams, making reference to the value in cell B13. 

11. 
Copy the formula in cell E2 into rows 3 to 11. 
Tip: you will have to use absolute addressing for the copying to work. 

12. In cell D12 use a function to total the Annual Salary 

13. Copy the function in D12 to cell E12 and make the totals Bold. 

14. 
Format columns C to E as currency, and make the column headings right-aligned.  
Increase the column widths if necessary so that all the data is displayed.. 

Open MS Excel 2010 and type the data below into a blank worksheet. Save the workbook on 
your F: drive with the name Excel-Task-1.xlsx 
 

When you’ve finished entering the data and have saved the workbook, follow the instructions 
below to format the worksheet, perform calculations, and create a chart. 
 

An example of what the final chart should look like, is shown at the end of the next page. 
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Now let’s try some more advanced tasks: 

15. 
Select cells A1 to E11 and add a Subtotal to the Monthly Salary for each change in 
Position. 

16. At level 2, select the four position subtotals (excluding the Grand Total). 

 
17. Insert a 2D Pie Chart based on the selected data. 

18. Use the Layout tab and Data Labels button to display Centred Data Labels. 

19. Drag the chart to just below your data. 

20. Save your worksheet one last time, with the same name and location. 

 
Well done! You’re well on your way to being a proficient Excel user! 


